Difference between revisions of "Mac OS X"

From Official Kodi Wiki
Jump to: navigation, search
 
(36 intermediate revisions by 5 users not shown)
Line 1: Line 1:
 
{{mininav|[[Devices]]}}
 
{{mininav|[[Devices]]}}
<section begin="intro" />XBMC for Mac runs natively on Mac OS X. Mac OS X can provide hardware video decoding for H.264 and MPEG2 video, though most CPUs are able to software decode other formats in 1080 as well. Macs can use the Apple TV remote, among others, for control of XBMC. An Intel Mac running OS X 10.6 or higher is required for XBMC.<section end="intro" />
+
{{forum link2|1=Read this page and still need help? Check out the [http://forum.kodi.tv/forumdisplay.php?fid=56 ''Kodi for OS X'' support forum].}}
  
{{incomplete}}
+
<section begin="intro" />Kodi for OS X runs natively on Mac OS X. OS X for Mac computers from Apple can provide hardware video decoding for H.264 and MPEG-2 video, though most CPUs are able to software decode other formats in 1080 as well. Macs can use the Apple TV remote, among others, for control of Kodi. An Intel Mac running OS X 10.7 (Lion) or higher is required for Kodi.<section end="intro" />
  
[[Category:Mac OS X|*]]
+
 
 +
== Main topics ==
 +
Other Mac-specific wiki pages for topics, guides, and advice. For [[Main_Page|everything else]], standard Kodi pages will normally apply.
 +
{{Index two column
 +
| image 1 = Gnome-emblem-downloads.png
 +
| link 1 = HOW-TO:Install_Kodi_for_Mac_OS_X
 +
| link name 1 = HOW-TO:Install Kodi for Mac OS X
 +
| image 2 = FAQ icon.png
 +
| link 2 = Mac_FAQ
 +
| link name 2 = Kodi for OS X specific FAQ
 +
| image 3 = Nuvola apps ksim.png
 +
| link 3 = Supported hardware
 +
| image 4 = Applications-development.png
 +
| link 4 = OS_X_development
 +
| link name 4 = Developing Kodi for OS X
 +
| link 5 = Supplemental tools
 +
| link name 5 = Supplemental tools
 +
| description 5 =
 +
}}
 +
 
 +
 
 +
 
 +
== Requirements ==
 +
{{see also|Supported hardware}}
 +
{{#lst:Supported hardware|Mac OS X}}
 +
 
 +
 
 +
 
 +
== How-tos ==
 +
<dpl>
 +
category = How-to
 +
category = Mac OS X
 +
format  = ,{{list2|%PAGE%}}
 +
</dpl>
 +
 
 +
 
 +
 
 +
 
 +
{{updated|18}}
 +
 
 +
[[Category:Apple]]
 
[[Category:Hardware]]
 
[[Category:Hardware]]
 
[[Category:Index]]
 
[[Category:Index]]
[[Category:XBMC Manual]]
+
[[Category:Manual]]

Latest revision as of 23:00, 19 June 2020

Home icon grey.png   ▶ Devices ▶ Mac OS X
Attention talk.png Read this page and still need help? Check out the Kodi for OS X support forum.

Kodi for OS X runs natively on Mac OS X. OS X for Mac computers from Apple can provide hardware video decoding for H.264 and MPEG-2 video, though most CPUs are able to software decode other formats in 1080 as well. Macs can use the Apple TV remote, among others, for control of Kodi. An Intel Mac running OS X 10.7 (Lion) or higher is required for Kodi.


1 Main topics

Other Mac-specific wiki pages for topics, guides, and advice. For everything else, standard Kodi pages will normally apply.

icon HOW-TO:Install Kodi for Mac OS X
icon Kodi for OS X specific FAQ
Frequently Asked Questions for OS X and Mac hardware from Apple.
icon Supported hardware
Kodi is officially supported on a number of operating systems and hardware devices that are designed to be connected directly to a TV. Kodi runs well on what are relatively "underpowered" systems, thanks to hardware video decoding being common on nearly all supported platforms. These requirements don't include what might be required for some "advanced" features, such as PVR, which might require additional hardware.
icon Developing Kodi for OS X
Team-Kodi (formerly called Team-XBMC) first ported XBMC Media Center software to Mac OS X in 2008, and the whole project cross-platform application was renamed to Kodi in 2014. Kodi itself is a huge open source project and it takes loads of people working together to maintain it for all platforms, that is why Team-Kodi is always on the lookout for C/C++ programmers to volunteer in assisting us with the development of Kodi. Whether you have contributed to the Kodi/XBMC project in the past or not, please consider doing so now.
icon Supplemental tools


2 Requirements

  • Kodi v17 requires Mac OS X 10.8 or later.
  • Kodi v18 (and its nightlies) will at least require 10.9)
  • All hardware requirements are the same as those for OS X 10.8. If your computer can run OS X 10.8 or later then your hardware should work just fine with Kodi.


3 How-tos

Extension:DynamicPageList (DPL), version 2.3.0 : Warning: No results.