Difference between revisions of "HOW-TO:Install Kodi for Linux"

From Official Kodi Wiki
Jump to navigation Jump to search
(Refactor Ubuntu installation guide)
Line 117: Line 117:


=== Debian ===
=== Debian ===
In Debian 9 (Stretch) and 10 (Buster), Kodi is available in the default "main" Debian repository. You can check this with 'apt show kodi' to show the description or 'apt policy kodi' to check available version and whether it's installed. The version in the Debian main repository is an older version (built by Debian) and is not maintained by the Kodi team.
Debian GNU/Linux ships its own '''Kodi from Debian''' flavor with following changes:
 
* Only system libraries are used (no embedded third-party libraries except of libdvdread and libdvdnav)
* Old web interface (Chorus) is shipped to ensure Debian Free Software Guides (DFSG) compatibility
 
as well as a subset of Kodi binary addons packaged in [https://qa.debian.org/[email protected] main repository of Debian].
 
 
{{Warning|'''Team Kodi offers no official support to "Kodi from Debian"!''' Please refer to links below for support!}}
 
The support for Kodi from Debian is provided via the following channels:
# [https://forum.kodi.tv/showthread.php?tid=363611 Kodi from Debian - Support Thread] on Kodi forums
# [https://github.com/xbmc/xbmc/issues Github issues]
# [https://bugs.debian.org Debian Bug Tracker]
 
 
==== Checking installed and available Kodi packages ====
 
You can check what versions of Kodi and its binary add-ons are installed with the following command:
 
<syntaxhighlight lang=bash>
dpkg -l | grep kodi
</syntaxhighlight>
 
To check what versions of Kodi are available, use this command:
 
<syntaxhighlight lang=bash>
apt-cache policy kodi*
</syntaxhighlight>
 
 
==== Installing Kodi on Debian Unstable or Testing ====
 
Installation of Kodi from Debian on Debian unstable ("sid") and testing is straightforward:


In Debian 9 and 10, update APT and install:
<syntaxhighlight lang=bash>
<syntaxhighlight lang=bash>
sudo apt update
sudo apt update
Line 125: Line 157:
</syntaxhighlight>
</syntaxhighlight>


To install Kodi binary add-ons (like '''PVR IPTV Simple''', for example):
<syntaxhighlight lang=bash>
sudo apt install kodi-pvr-iptvsimple
</syntaxhighlight>
==== Installing Kodi on Debian 10 "buster" ====
By default, Debian buster users get Kodi 17.6 "Krypton". However, it is possible to get Kodi 19.x "Matrix" from buster-backports.


For installation if you are using Debian 8 (Jessie), you can use the debian-backports repository.


Add the following lines to your /etc/apt/sources.list file, as superuser (sudo)
To get Kodi 17.6 and the corresponding add-ons, use the method described in '''Debian Unstable or Testing''' section above.


<syntaxhighlight lang=bash>
# kodi repos
# starting with debian jessie, debian provides kodi via its backports repository
# remember: those packages are not supported by team kodi
deb http://http.debian.net/debian jessie-backports main
</syntaxhighlight>


And then, update APT and install Kodi.
To get Kodi 19.x and the corresponding add-ons from Debian Backports:


<syntaxhighlight lang=bash>
<syntaxhighlight lang=bash>
# Add Debian Backports repository for Debian 10 "buster"
if ! apt-cache policy 2>/dev/null | grep -q "http://.*buster-backports"; then
  echo "deb http://deb.debian.org/debian/ buster-backports main contrib" | sudo tee /etc/apt/sources.list.d/buster-backports.list
fi
# Update APT lists
sudo apt-get update
sudo apt-get update
sudo apt-get install kodi
 
# Install Kodi from backports:
sudo apt-get install {kodi,kodi-bin,kodi-data,kodi-repository-kodi,libspdlog1}/buster-backports
 
# (OPTIONAL) Install Kodi binary add-ons (for example, 'PVR IPTV Simple'):
sudo apt-get install kodi-pvr-iptvsimple/buster-backports
</syntaxhighlight>
</syntaxhighlight>
==== Installing Kodi on Debian 9 "stretch" ====
By default, Debian stretch users get Kodi 17.1 "Krypton". No higher version is packaged in backports.
To get Kodi 17.1 and the corresponding add-ons, use the method described in '''Debian Unstable or Testing''' section above.





Revision as of 08:31, 18 July 2021

Home icon grey.png   ▶ Linux
▶ Installing
▶ HOW-TO:Install Kodi for Linux

1 Installing Kodi on Ubuntu-based distributions with Team Kodi PPA

The recommended way of installing Kodi on Ubuntu and its derivatives (Linux Mint, Kali Linux, Pop! OS etc) is to use official Team Kodi PPA.

Stop hand.png Ubuntu releases 16.04 LTS ("Xenial") or later, respectively, include their own Kodi builds in their official package repositories, customized to satisfy their interpretations of what is acceptable under their open-source mandates. If you have installed your distribution's Kodi packages, please purge them using the command sudo apt purge kodi* before trying to install team-xbmc PPA packages.


Stop hand.png Releases from Team Kodi PPA are NOT compatible with Debian GNU / Linux and distributions built on top of Debian's binary package repositories! Please refer to Debian section of this page for installation instructions on such distributions!


See SFTP or Click here to find out how to use the terminal.


1.1 Adding Team Kodi PPA repository

Use the command line terminal in Ubuntu, and enter the following commands. Follow the prompts as you would any other software installation.

sudo apt install software-properties-common
sudo add-apt-repository -y ppa:team-xbmc/ppa
sudo apt install kodi


The Kodi repositories are as follows:

Note: Although the URL still has "Team XBMC" in the title, these are the current URLs for Kodi.

https://launchpad.net/~team-xbmc/+archive/ppa ppa:team-xbmc/ppa Final release builds
https://launchpad.net/~team-xbmc/+archive/unstable ppa:team-xbmc/unstable Betas and release candidates
https://launchpad.net/~team-xbmc/+archive/xbmc-nightly ppa:team-xbmc/xbmc-nightly Nightly builds

Note that this PPA only provides builds for Ubuntu i386 and Ubuntu amd64 but not for Ubuntu armhf, which can run on a Raspberry Pi.


1.2 Installing binary add-ons (PVR, audio decoders, audio encoders, screensavers, visualizations, audio DSP)

See: Ubuntu binary add-ons


1.3 Installing a development build

To install a beta/unstable version of Kodi you must first add the unstable repository, then install XBMC. Use ppa:team-xbmc/xbmc-nightly for nightly builds and ppa:team-xbmc/unstable for beta builds.

sudo apt install software-properties-common
sudo add-apt-repository -y ppa:team-xbmc/xbmc-nightly
sudo apt install kodi

Note that if you have any addons (such as PVR clients), these must be updated as well (they will not be updated automatically):

sudo apt install kodi-pvr-mythtv


1.4 Upgrading

To update Kodi when a new version is released, just do a general system/package or use the following commands in the terminal (or via SFTP):

sudo apt update
sudo apt upgrade --with-new-pkgs


1.5 Downgrading to a stable version from a development version

If you install a nightly build or an unstable release and want to return to a stable release, follow these instructions:

Remove the unstable or nightly PPA:

apt-cache policy | grep -Eo 'team-xbmc/(unstable|nightly)' | sudo xargs -r add-apt-repository -ryP

Then restore the stable version with the following commands:

sudo add-apt-repository ppa:team-xbmc/ppa
sudo apt-get update
sudo apt-get remove kodi kodi-x11
sudo apt-get install kodi


1.6 Downgrading between newer and older stable versions

If you want to return to the next most recent stable release, follow these instructions:

Remove the current stable packages and PPA:

sudo apt purge kodi*
sudo add-apt-repository -r ppa:team-xbmc/ppa

Then install the "oldstable" version with the following commands:

sudo add-apt-repository -y ppa:team-xbmc/kodi-old
sudo apt install kodi


1.7 Reverting to an earlier nightly

ALthough launchpad doesn't list older nightlies in their PPA, they are usually still available for download directly from the website. Visit the xbmc-nightly repository index, where you will then have to download the appropriate .deb files and manually install them using sudo dpkg -i [path to downloaded file].


1.8 Uninstalling

If you need to uninstall Kodi and purge its global configuration files (for instance, in the attempt to troubleshoot a persistent crash or other errors), do so by using the first of the following commands. If that fails to solve the issue, you will likely need to remove your user settings folder with all of your settings and library data to return to a state equivalent to what existed before Kodi was first installed on the system. This will not delete any videos or music, but just the settings and library data itself, but it is still recommended to keep a backup of them in case it's discovered that they weren't at issue and you are able to effect another solution. An example of how to accomplish a backup and then deletion of your user settings is provided on the last two lines, the highlighted one being responsible for making the backup which can thereafter be found in your home folder with the filename kodi-backup_timestamp.tar.xz.

sudo apt purge kodi*
tar cf - "${HOME}/.kodi/" | xz -z9e - >"${HOME}/kodi-backup_$(date +%m%d%y-%H%M).tar.xz"
rm -Ri "${HOME}/.{kodi,xbmc}/"

2 Embedded/Appliance type install

2.1 LibreELEC

LibreELEC (short for "Libre Embedded Linux Entertainment Center") is small and very fast booting, open source JeOS (Just enough Operating System). LibreELEC is a complete media center software suite for embedded systems and computers, as it comes with a pre-configured version of Kodi and optional third-party PVR backend software.


3 Third Party Repositories

The instructions in this section are for unofficial Linux binaries that are un/semi supported by Team Kodi. Most of those binaries use system ffmpeg or even worse totally untested libav, which is not recommended for Kodi as we support ffmpeg only.


3.1 Debian

Debian GNU/Linux ships its own Kodi from Debian flavor with following changes:

  • Only system libraries are used (no embedded third-party libraries except of libdvdread and libdvdnav)
  • Old web interface (Chorus) is shipped to ensure Debian Free Software Guides (DFSG) compatibility

as well as a subset of Kodi binary addons packaged in main repository of Debian.


Stop hand.png Team Kodi offers no official support to "Kodi from Debian"! Please refer to links below for support!


The support for Kodi from Debian is provided via the following channels:

  1. Kodi from Debian - Support Thread on Kodi forums
  2. Github issues
  3. Debian Bug Tracker


3.1.1 Checking installed and available Kodi packages

You can check what versions of Kodi and its binary add-ons are installed with the following command:

dpkg -l | grep kodi

To check what versions of Kodi are available, use this command:

apt-cache policy kodi*


3.1.2 Installing Kodi on Debian Unstable or Testing

Installation of Kodi from Debian on Debian unstable ("sid") and testing is straightforward:

sudo apt update
sudo apt install kodi

To install Kodi binary add-ons (like PVR IPTV Simple, for example):

sudo apt install kodi-pvr-iptvsimple


3.1.3 Installing Kodi on Debian 10 "buster"

By default, Debian buster users get Kodi 17.6 "Krypton". However, it is possible to get Kodi 19.x "Matrix" from buster-backports.


To get Kodi 17.6 and the corresponding add-ons, use the method described in Debian Unstable or Testing section above.


To get Kodi 19.x and the corresponding add-ons from Debian Backports:

# Add Debian Backports repository for Debian 10 "buster"
if ! apt-cache policy 2>/dev/null | grep -q "http://.*buster-backports"; then
  echo "deb http://deb.debian.org/debian/ buster-backports main contrib" | sudo tee /etc/apt/sources.list.d/buster-backports.list
fi

# Update APT lists
sudo apt-get update

# Install Kodi from backports:
sudo apt-get install {kodi,kodi-bin,kodi-data,kodi-repository-kodi,libspdlog1}/buster-backports

# (OPTIONAL) Install Kodi binary add-ons (for example, 'PVR IPTV Simple'):
sudo apt-get install kodi-pvr-iptvsimple/buster-backports


3.1.4 Installing Kodi on Debian 9 "stretch"

By default, Debian stretch users get Kodi 17.1 "Krypton". No higher version is packaged in backports.

To get Kodi 17.1 and the corresponding add-ons, use the method described in Debian Unstable or Testing section above.


3.2 Raspbian

Installing on Raspbian is done with:

sudo apt-get install kodi

Upgrading on Raspbian is done with:

sudo apt-get update
sudo apt-get upgrade


4 Installation from source

If distribution packages are not available, or you need a newer version, or specific features enabled, then you will most likely need to compile from source. See our Compiling Kodi guide.