Archive:Gotham API changes

From Official Kodi Wiki
(Redirected from Gotham API changes)
Jump to: navigation, search
Home icon grey.png   ▶ Releases
▶ Development
▶ Gotham API changes

1 Gotham changelog


2 Addons

Any add-ons that are submitted for inclusion in Gotham repository will require compatibility with the new APIs. If the addon does not use new APIs that are only available in Gotham the same version can be submitted to Frodo repository. If it does rely on new API features you need to submit two separate versions, one for Frodo only compatible and one for Gotham. The addon version for Gotham needs to be higher than the one for Frodo.

Be sure to read the Official Repository Guidlines before submitting a pull request.

If you are going to submit your addon to the Gotham addon repo and your addon depends on any of internal xbmc addons, please make sure you depend on a x.y.z version.

The current versions for Frodo are as listed below:

  • xbmc.addon : 12.0.0
  • xbmc.core : 0.1.0
  • xbmc.gui : 4.0.0 (will be changed to 5.0.0 when releases)
  • xbmc.json : 6.0.0
  • xbmc.metadata : 2.1.0
  • xbmc.python : 2.1.0


Tip Tip: See Official add-on repository

3 Skins

Tip Tip: See Official add-on repository

4 JSON-RPC

4.1 API

4.1.1 Changed Methods

  •  ?

4.1.2 New Methods

  •  ?

4.1.3 New Notifications

  •  ?

4.2 Miscellaneous

  •  ?

5 Webserver

5.1 General

  •  ?

5.2 JSON-RPC Handler /jsonrpc

  •  ?

6 Scrapers

  •  ?

7 Screensavers and visualizations

  •  ?

8 References