Linux

From Official Kodi Wiki
Revision as of 04:49, 28 July 2020 by Karellen (talk | contribs)
Jump to: navigation, search
Home icon grey.png   ▶ Devices ▶ Linux
Attention talk.png Read this page and still need help? Check out the Kodi for Linux discussion forum.

Kodi for Linux is primarily developed for Ubuntu Linux. Third-party packages for most other Linux distributions are however available, and it is also possible to compile Kodi media center software application from scratch for nearly any Linux distribution. Linux supports full hardware decoding with most graphics cards. Linux is generall the best way to get a fast, free, and "appliance" feel for an Kodi powered HTPC.

1 Main topics

Other Linux-specific wiki pages for topics, guides, and advice. For everything else, standard Kodi pages will normally apply.

icon HOW-TO:Install Kodi for Linux
icon Supported hardware
Kodi is officially supported on a number of operating systems and hardware devices that are designed to be connected directly to a TV. Kodi runs well on what are relatively "underpowered" systems, thanks to hardware video decoding being common on nearly all supported platforms. These requirements don't include what might be required for some "advanced" features, such as PVR, which might require additional hardware.
icon Linux_development
Team-Kodi (formerly called Team-XBMC) first ported XBMC Media Center software to Linux in 2007, and the whole project cross-platform application was renamed to Kodi in 2014. Kodi itself is a huge open source project and it takes loads of people working together to maintain it for all platforms, that is why Team-Kodi is always on the lookout for C/C++ programmers to volunteer in assisting us with the development of Kodi. Whether you have contributed to the Kodi/XBMC project in the past or not, please consider doing so now.
icon Ubuntu binary add-ons
How to install certain binary add-ons for Ubuntu, such as PVR, audio decoder/encoders, audio DSP, screensavers, and visualizations.

2 Requirements

CPU x86 or x86-64 processor such as: Intel Pentium 4/ Pentium M, AMD Athlon 64 / Opteron, or newer CPU (that support SSE2, which all CPUs made within the last 10-years does).
  • If your GPU/VPU does not support hardware video decoding then you will require a fast modern processor is required to decode some 1080p videos encoded in H.264, VC-1/WMV9, HEVC/H.265 VP9, etc
RAM
  • Recommended: 1GB or more in a HTPC media player appliance-like computer dedicated for Kodi, and 2GB or more in a computer for multipurpose use.
Graphics

Kodi will run on most graphics cards made within the last 10-years or so, though for good hardware video decoding support a little newer graphics cards can be required. This includes most cards from AMD/ATI, Intel, or NVIDIA which support OpenGL 2.0 or later.

AMD/Intel

Video decoding For hardware video decoding, which may be necessary on low-performance CPUs to playback 1080p content, make sure your GPU or VPU supports either VAAPI or VDPAU. For everything but older AMD cards and Nvidia, VAAPI is recommended. On AMD, you might have to start with the environment variable KODI_GL_INTERFACE set to GLX in order to get VDPAU support.
ATI ( VA-API minimum 2.0.0 or VDPAU ) Intel ( VA-API minimum 1.7.1 ) Nvidia ( VDPAU )
Minimum without HW decoding: ATI Radeon RV710/M92 (HD 4300/4500) Note: These are uvd2.2 cards Arrandale / Clarkdale or newer Nvidia GeForce 6-Series
Minimum for HW decoding of 8-bit H.264 and VC-1: AMD/ATI Radeon HD 5000 Series or newer Bay Trail /Sandybridge or newer Nvidia GeForce 8-Series or newer
Minimum for HW decoding of 8-bit HEVC (H.265): AMD Radeon Rx 300 series or newer Braswell / Skylake or newer Nvidia GeForce 900 series (GM20x) or newer
Minimum for HW decoding of 10-bit HEVC (H.265): AMD Radeon 400 series or newer Apollo Lake / Kaby Lake or newer Not available
Minimum for HW decoding of VP9: Stoney Ridge APU or newer; not available for desktop GPUs at the moment Apollo Lake / Kaby Lake or newer Not available
Drive space The Kodi application generally only takes up between 100 to 200 MB of space, depending on how the binary is compiled. Technically speaking, if your hardware supports netbooting, you do not even require a internal storage for either the operating-system or for Kodi.
  • Minimum: 4 to 8GB
  • Recommended: 16GB or more
Depending on how big your video library is. Most of the space required for Kodi comes from the images/artwork cache.

Note: There´s no 304.xxx driver for Ubuntu 18.04 available anymore from the "Graphic Drivers"-ppa. Users who are using GeForce 6-series cards should either stay on an older Ubuntu version or use newer cards


3 Linux distributions

For install instructions for various Linux distros, see HOW-TO:Install Kodi for Linux.

Note: Your Linux distribution must include version 1.7 or newer of the Python cryptography module or you will encounter very strange behavior related to add-ons and internet access. If you are running Ubuntu 16.04 or another older Debian-based distribution, see https://forum.kodi.tv/showthread.php?tid=304613&pid=2562213#pid2562213 for a possible solution.

3.1 x86

3.2 ARM

Raspberry Pi
SolidRun CuBox-i / CuBoxTV
Other

4 How-tos

Archive:Compile Kodi on openSUSE
HOW-TO:Install Kodi for Linux
HOW-TO:Set up LIRC
HOW-TO:Set up Wake-on-LAN for Ubuntu
Ubuntu binary add-ons
How to install certain binary add-ons for Ubuntu, such as PVR, audio decoder/encoders, audio DSP, screensavers, and visualizations.


5 Device specific info

Stop hand.png These pages are maintained by the community and should not be considered an endorsement or recommendation. Device pages are made when there's a bunch of useful information for a particular device, and someone takes the time to make that page. Keep in mind, some devices simply don't need a page of specific information, but are still excellent devices. *


Extension:DynamicPageList (DPL), version 2.3.0 : Warning: No results.


6 See also