Difference between revisions of "Archive:Kodibuntu FAQ"

From Official Kodi Wiki
Jump to: navigation, search
m (What are XBMCbuntu's minimum requirements?: use section lst like other stuff.)
m (Move talk page over to main)
Line 1: Line 1:
 
{{mininav|[[General topics]]{{l2|[[Devices]]}}|[[FAQs]]{{l2|[[XBMCbuntu]]}}|page=XBMCbuntu FAQ }}
 
{{mininav|[[General topics]]{{l2|[[Devices]]}}|[[FAQs]]{{l2|[[XBMCbuntu]]}}|page=XBMCbuntu FAQ }}
{{wiki revamp}}
+
{{forum link|114104}}
 +
 
 
{{FAQ header|for XBMCbuntu}}
 
{{FAQ header|for XBMCbuntu}}
 
:{{See also| XBMCbuntu}}<br />
 
:{{See also| XBMCbuntu}}<br />
Line 7: Line 8:
 
__TOC__
 
__TOC__
 
{{-}}
 
{{-}}
 +
 
== General FAQ ==
 
== General FAQ ==
 
:<big>''See also: '''[[XBMC all platforms FAQ]]''' for FAQs that apply to all versions of XBMC.''</big>
 
:<big>''See also: '''[[XBMC all platforms FAQ]]''' for FAQs that apply to all versions of XBMC.''</big>
:<big>''See also: '''[[XBMC v13 (Gotham) FAQ]]''' for FAQs related to the (Frodo) v12 release.''</big>
+
:<big>''See also: '''[[XBMC v13 (Gotham) FAQ]]''' for FAQs related to the (Gotham) v13 release.''</big>
=== What is XBMCbuntu? ===
 
:'''XBMCbuntu''' is the XBMC Media Center software bundled with a embedded operating-system, for that set-top-box feeling. XBMCbuntu also lets you easily boot the XBMCbuntu CD in order to demo XBMC for your friends and family on practically any relatively modern computer, (as long as it was manufactured in the last 5-years or so it should meet the XBMC's minimum requirements).
 
 
 
:XBMCbuntu '''.iso''' [[XBMCbuntu/FAQ#Get and Install XBMCbuntu|can also be used to create a bootable USB disk]] with a completely independent OS which can be booted, thus not requiring any modifications to the host PC disk.
 
 
 
=== What version of Ubuntu is used by the current XBMCbuntu? ===
 
: Lubuntu 12.10 (Quantal Quetzal)
 
 
 
=== How can I transfer files to/from XBMCbuntu? ===
 
Use SFTP with a client such as Cyberduck or FileZilla or scp via SSH within Linux/OS X shell. '''username and password''' is '''xbmc''' '''blank''' or the xbmc password selected during install.
 
 
 
:''See also:'' [[SFTP|Connecting to XBMCbuntu via SFTP]]
 
:''See also:'' [[SSH|Connecting to XBMCbuntu via SSH]]
 
  
=== How can I backup all my settings to restore them if something goes wrong? ===
+
{| width="100%"
You can use the [[Add-on:XBMC Backup]] Backup and restore your XBMC database and configuration files in the event of a crash or file corruption.
+
{{FAQ|1=XBMC|2=What_is_it
 +
| BGcolor=WhiteSmoke
 +
| Question=What is XBMCbuntu?
 +
| Answer=
 +
{{#lst:XBMCbuntu|intro}}
 +
}}
  
Alternatively if you do not wish to use a addon, you can navigate to your [[userdata]] folder and copy/archive all its contents to a external drive. This can be achieved various ways, depending on your OS.
+
{{FAQ|1=what_is_the_iso
 +
| BGcolor=
 +
| Question=What is the XBMCbuntu.iso?
 +
| Answer=
 +
:The XBMCbuntu '''.iso''' is a Lubuntu based Linux distro, customised to provide point releases of XBMC like v13 Gotham. [[XBMCbuntu/FAQ#Get and Install XBMCbuntu|can also be used to create a bootable USB disk]].
 +
:Because of the nature of Live facilities of Linux distros available in XBMCbuntu, you can also try-it-out without installing, thus not requiring any modifications to the host harddrive.
 +
}}
  
=== What are the minimum requirement and recommended hardware for XBMC? ===
+
{{FAQ|1=what_version
 +
| BGcolor=WhiteSmoke
 +
| Question=What version of Lubuntu is used by the current XBMCbuntu?
 +
| Answer=
 +
: For Gotham v13, the XBMCbuntu is based on Lubuntu 14.04LTS (Trusty Tahr)
 +
}}
  
:For end-users the recommended minimum requirement is a [http://en.wikipedia.org/wiki/X86 x86-based computer], with a [http://en.wikipedia.org/wiki/Graphics_Processing_Unit 3D GPU (Graphics Processing Unit)] that at least supports [http://en.wikipedia.org/wiki/Shader_model Shader Model 3.0] and [http://en.wikipedia.org/wiki/OpenGL OpenGL 2.0] (that features 24bpp or 32bpp for 3D hardware-acceleration support, which XBMC GUI need to run smoothly at an acceptable frame-rate). Graphic adapters that support [http://en.wikipedia.org/wiki/DirectX DirectX version 9.0c] or later usually meet all of those mentioned requirements, ([[Team-XBMC]] recommends [http://en.wikipedia.org/wiki/Nvidia NVIDIA GeForce 6150 or later] as NVIDIA are currently the manufacturer that offers [http://en.wikipedia.org/wiki/Graphics_hardware_and_FOSS good device-drivers for Linux] (and [http://en.wikipedia.org/wiki/Nvidia NVIDIA GeForce 6150 or later] supports OpenGL 2.0).
+
{{FAQ|1=Minimum_requirements
 
+
| BGcolor=
=== What are XBMCbuntu's minimum requirements? ===
+
| Question=What are XBMCbuntu's minimum requirements?
 +
| Answer=
 
{{#lst:XBMCbuntu|XBMCbuntu_hw}}
 
{{#lst:XBMCbuntu|XBMCbuntu_hw}}
 +
}}
 +
|}
  
== '''Why do I get no audio devices detected ?''' ==
+
== Installation==
:<big>'''''See: [[XBMCbuntu#XBMCbuntu no audio devices|XBMCbuntu no audio devices''''']]</big>
+
{| width="100%"
 +
{{FAQ|1=Get_and_install_XBMCbuntu
 +
| BGcolor=WhiteSmoke
 +
| Question=How do I get and install XBMCbuntu?
 +
| Answer=
 +
{{#lst:XBMCbuntu|getandinstallxbmcbuntu}}
 +
}}
  
== How do I get and Install XBMCbuntu ? ==
+
{{FAQ|1=problems_installing
For instructions on how to acquire, create a bootable usb flash drive, boot or install to/from
+
| BGcolor=
 +
| Question=How do I resolve any install wizard's problems?
 +
| Answer=
 +
In the event, the XBMCbuntu install wizard isn't working for you, when selecting install from the grub menu options, do the following:
 +
{{#lst:XBMCbuntu|problematic_wizard}}
 +
}}
 +
== Upgrading ==
 +
{| width="100%"
 +
{{FAQ|1=upgrading_via_ppa
 +
| BGcolor=
 +
| Question=How do I upgrade XBMC from PPA in XBMCBuntu?
 +
| Answer=
 +
You dont have to necessarily wipe your current install '''to try a new version of XBMC''', like a '''nightly version''' or '''beta''' for example, you can just "fire up" Putty or a shell in Linux/OS X
 +
;:See below:
 +
}}
 +
|}
  
<big>'''''See: ''[[Create and install from/to a bootable USB flash drive]]'''</big>
+
{| class="wikitable" style="background-color:#ffffff;"
 +
{{#lst:Team_XBMC_PPA|repos}}
 +
{{#lst:Team_XBMC_PPA|upgrading_xbmc}}
 +
|}
  
=== Resolving problematic installs ===
+
== Drivers ==
 +
{| width="100%"
 +
{{FAQ|1=upgrade_drivers
 +
| BGcolor=whitesmoke
 +
| Question=How can I Upgrade NVidia drivers in Ubuntu/XBMCbuntu and variants?
 +
| Answer=
 +
<section begin="Upgrade_nvidia_driver />
 +
Nvidia as well as drivers suppliers for Ubuntu and variants, recommended user to install these packages via repositories provided!
 +
The maintainers ensure the drivers are correct and compatible to the distro being targeted.
  
# Boot your system with the installer thumbdrive and select the "Try Ubuntu" option.  This should boot into XBMC.
+
<syntaxhighlight lang="bash" enclose="div">
# Click the Shutdown menu in XBMC (lower-left corner) and select "Exit"
+
sudo apt-get install python-software-properties pkg-config
# You should be presented with a log-in screen.  Click "Other..." and enter '''xbmc''' as the login and select '''XBMCbuntu''' from the dropdown menu (below the Login field).
+
sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
# Click "Login" and you will be prompted for the Password;  just leave it blank.
+
sudo apt-get update
# Click "Login" again and the XBMCbuntu desktop should be displayed.
+
sudo apt-get install nvidia-current nvidia-settings
# On the top-left corner of the desktop should be an icon to install Ubuntu.  Double-click the icon and, hopefully, you'll get the installation wizard this time.
+
</syntaxhighlight><br />
  
=== Upgrading XBMC via ppa in XBMCbuntu ===
+
{{forum link2|[[forum:142220|Nvidia Drivers updates XBMCBuntu]].Ubuntu and variants forum discussion thread}}<br />
You dont have to necessarily wipe your current install to try a new Version of XBMC, like a nightly version or beta for example, you can just fire up Putty or a shell in Linux/OS X
+
}}<section end="Upgrade_nvidia_driver" />
 +
|}
  
:'''''see also:''''' [[SSH|'''Connecting to XBMCbuntu via SSH''']]
+
== Handling files & Backups==
  
:'''''see also:''''' [[XBMC for Linux specific FAQ#Where are XBMC Packages for Ubuntu.2FDebian.3F|'''Where are XBMC Packages for Ubuntu/Debian''']]
+
{| width="100%"
 +
{{FAQ|1=transferring_files
 +
| BGcolor=#ffffff
 +
| Question=How can I transfer files to/from XBMCbuntu?
 +
| Answer=
 +
Use SFTP with a client such as Cyberduck or FileZilla or scp via SSH within Linux/OS X shell. '''username and password''' is '''xbmc''' '''blank''' or the xbmc password selected during install.
  
:'''''see also: '''''[[XBMC v12 (Frodo) FAQ#What might break when upgrading to v12.3F .28Audio and Video.2C add-ons.2C skins.2C remotes.29|'''What might break when upgrading to v12''']]<br />
+
:''See also:'' [[SFTP|Connecting to XBMCbuntu via SFTP]]
 +
:''See also:'' [[SSH|Connecting to XBMCbuntu via SSH]]
 +
}}
 +
|}
  
<syntaxhighlight lang="bash" enclose="div">
+
{| width="100%"
sudo apt-get install python-software-properties pkg-config
+
{{FAQ|1=Backup
sudo add-apt-repository -r ppa:current_XBMC_providing_ppa
+
| BGcolor=whitesmoke
sudo add-apt-repository ppa:the_ppa_you_wish_to_use
+
| Question=How can I backup all my settings to restore them if something goes wrong?
 +
| Answer=
 +
You can use the [[Add-on:XBMC Backup]] Backup and restore your XBMC database and configuration files in the event of a crash or file corruption.
  
sudo apt-get update
+
Alternatively if you do not wish to use a addon, you can navigate to your [[userdata]] folder and copy/archive all its contents to a external drive. This can be achieved various ways, depending on your OS.
sudo apt-get upgrade
+
{{see also|HOW-TO:Backup_the_library}}
sudo apt-get install xbmc xbmc.bin
+
}}
</syntaxhighlight>
+
|}
  
{{note|The first 3 lines only needed if you have a testing ppa or unstable ppa providing xbmc and want to insert a different source, otherwise its '''only run the last 3 lines to upgrade, since XBMCbuntu already has a providing ppa this is the ppas you want <code>ppa:team-xbmc/ppa</code>'''}}
+
== Connectivity ==
 +
{| width="100%"
 +
{{FAQ|1=connectivity
 +
| BGcolor=
 +
| Question=How can I connect a bluetooth keyboard/mouse/remote??
 +
| Answer=
 +
A good way to decipher this is to:
 +
:See this video:http://lubuntu.net/blog/lubuntu-screencast-bluetooth
 +
}}
 +
|}
  
=== Upgrading NVidia drivers in Ubuntu and variants ===
+
== Troubleshooting ==
  
<syntaxhighlight lang="bash" enclose="div">
+
{| width="100%"
sudo apt-get install python-software-properties pkg-config
+
{{FAQ|1=audio_issues
sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
+
| BGcolor=whitesmoke
sudo apt-get update
+
| Question=What if I have audio issues with XBMCbuntu?
sudo apt-get install nvidia-current nvidia-settings
+
| Answer=
</syntaxhighlight><br />
+
You can look at the audio troubleshooting page below, if your problems persist, you can always try to search for answers to your problem in forums and if none are found open your own thread.
 
+
Remember to have '''[[Debug log]]''' handy in pastebin, in such cases.
{{forum link2|[[forum:142220|Nvidia Drivers updates XBMCBuntu, Ubuntu and variants forum discussion thread]]}}<br />
+
:<big>'''''See: [[Audio_Troubleshooting|Audio Troubleshooting]]</big>
 
+
}}
== How can I connect a bluetooth keyboard/mouse/remote? ==
 
:See this video:http://lubuntu.net/blog/lubuntu-screencast-bluetooth
 
  
== Can't install because the install window is too big? ==
+
{{FAQ|1=window_too_big
 +
| BGcolor=
 +
| Question=Can't install, because the install window is too big?
 +
| Answer=
 +
In the event you come across this issue, you can look at adapting the solutions proposed in the forum post below.
 
:See [[forum:126453|Can't install because the install window is too big?]]
 
:See [[forum:126453|Can't install because the install window is too big?]]
 +
}}
  
== Can't install because the text is too small? ==
+
{{FAQ|1=text_too_small
 +
| BGcolor=whitesmoke
 +
| Question=Can't install because the text is too small?
 +
| Answer=
 +
In the event you come across this issue, you can look at adapting the solutions proposed in the forum post below.
 
:See [[forum:126453|Can't install because the text is too small?]]
 
:See [[forum:126453|Can't install because the text is too small?]]
 +
}}
 +
|}
  
 
== Known issues ==
 
== Known issues ==
Line 100: Line 169:
 
[[Category:FAQ|Live]]
 
[[Category:FAQ|Live]]
 
[[Category:XBMCbuntu]]
 
[[Category:XBMCbuntu]]
{{Frodo updated}}
+
{{Gotham updated}}

Revision as of 08:58, 30 March 2014

Home icon grey.png   ▶ General topics
▶ Devices
▶ FAQs
▶ XBMCbuntu
▶ XBMCbuntu FAQ
Attention talk.png For discussion about this page please see this Kodi forum post.

Frequently Asked Questions for XBMCbuntu


Template:XBMC FAQ


1 General FAQ

See also: XBMC all platforms FAQ for FAQs that apply to all versions of XBMC.
See also: XBMC v13 (Gotham) FAQ for FAQs related to the (Gotham) v13 release.

1.1 What is XBMCbuntu?

Link

XBMCbuntu

1.2 What is the XBMCbuntu.iso?

Link
The XBMCbuntu .iso is a Lubuntu based Linux distro, customised to provide point releases of XBMC like v13 Gotham. can also be used to create a bootable USB disk.
Because of the nature of Live facilities of Linux distros available in XBMCbuntu, you can also try-it-out without installing, thus not requiring any modifications to the host harddrive.

1.3 What version of Lubuntu is used by the current XBMCbuntu?

Link
For Gotham v13, the XBMCbuntu is based on Lubuntu 14.04LTS (Trusty Tahr)

1.4 What are XBMCbuntu's minimum requirements?

Link

XBMCbuntu

2 Installation

2.1 How do I get and install XBMCbuntu?

Link

XBMCbuntu

2.2 How do I resolve any install wizard's problems?

Link

In the event, the XBMCbuntu install wizard isn't working for you, when selecting install from the grub menu options, do the following: XBMCbuntu

3 Upgrading

3.1 How do I upgrade XBMC from PPA in XBMCBuntu?

Link

You dont have to necessarily wipe your current install to try a new version of XBMC, like a nightly version or beta for example, you can just "fire up" Putty or a shell in Linux/OS X

See below
Team XBMC PPATeam XBMC PPA

4 Drivers

4.1 How can I Upgrade NVidia drivers in Ubuntu/XBMCbuntu and variants?

Link

Nvidia as well as drivers suppliers for Ubuntu and variants, recommended user to install these packages via repositories provided! The maintainers ensure the drivers are correct and compatible to the distro being targeted.

sudo apt-get install python-software-properties pkg-config
sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get install nvidia-current nvidia-settings

Attention talk.png Nvidia Drivers updates XBMCBuntu.Ubuntu and variants forum discussion thread

5 Handling files & Backups

5.1 How can I transfer files to/from XBMCbuntu?

Link

Use SFTP with a client such as Cyberduck or FileZilla or scp via SSH within Linux/OS X shell. username and password is xbmc blank or the xbmc password selected during install.

See also: Connecting to XBMCbuntu via SFTP
See also: Connecting to XBMCbuntu via SSH

5.2 How can I backup all my settings to restore them if something goes wrong?

Link

You can use the Add-on:XBMC Backup Backup and restore your XBMC database and configuration files in the event of a crash or file corruption.

Alternatively if you do not wish to use a addon, you can navigate to your userdata folder and copy/archive all its contents to a external drive. This can be achieved various ways, depending on your OS.

6 Connectivity

6.1 How can I connect a bluetooth keyboard/mouse/remote??

Link

A good way to decipher this is to:

See this video:http://lubuntu.net/blog/lubuntu-screencast-bluetooth

7 Troubleshooting

7.1 What if I have audio issues with XBMCbuntu?

Link

You can look at the audio troubleshooting page below, if your problems persist, you can always try to search for answers to your problem in forums and if none are found open your own thread. Remember to have Debug log handy in pastebin, in such cases.

See: Audio Troubleshooting

7.2 Can't install, because the install window is too big?

Link

In the event you come across this issue, you can look at adapting the solutions proposed in the forum post below.

See Can't install because the install window is too big?

7.3 Can't install because the text is too small?

Link

In the event you come across this issue, you can look at adapting the solutions proposed in the forum post below.

See Can't install because the text is too small?

8 Known issues

See: XBMC v12 (Frodo) issues