User:uNiversal

From Official Kodi Wiki
Jump to: navigation, search


Done especially for xbmc Settings menu Click here to see forums thread
uNiversal
uNiversal
Error! Out of Memory!
XBMC user
System Details: Linux.4.0~Custom
Brain Version: Positronic 2.0
Power Matrix: Hybrid/Biologic
Ctrl+Alt+Del


100% Completed


Contents

1 Sandbox

2 video Hardware

Hardware and video playback compatibility
HTPC Hardware External Equipment Decoder Video Capabilities
Operative
System
Driver XBMC
Version
Model GPU - VPU type CPU type Code Names Limitation Plug AVR Television GPU
VPU
CPU
H.262 H.263 H.264 H.265 MPEG-4v3 WMV On2 720/1080 Blu-ray 3D Version Limitation
Some ficticious ugabuga holahoops armadillo Yes HDMI AVRBONGO Smugsung cpu gpu cpu No No No Yes Yes N/A Yes some os N/A w.i.p. V12.3
R-type MXU Positronic Quantum X armadillo Yes HDMI AVRBONGO Smugsung vpu vpu cpu No No No Yes Yes N/A Yes LinWinDrA No w.i.p. V14-alpha1-7asd43e

3 audio hardware

Hardware and audio playback compatibility
HTPC Hardware External Equipment Audio Capabilities
Operative
System
Driver XBMC
Version
Model GPU - VPU type Audio device Code Name Limitation Plug Receiver Television AC3 LPCM DTS DTS-HD MA DTS-HD TrueHD DD+/E-AC3 Version Limitation
ASRock E350M1 Radeon HD 6310 ? Wrestler No HDMI Onkyo HT-R380 ? Yes ? Yes Yes Yes Yes ? Windows 8 Pro, x64 13.2 Beta6 No ?
ASRock E350M1 Radeon HD 6310 ? Wrestler No HDMI Onkyo HT-R380 ? Yes ? Yes No No No ? OpenELEC 3.0 RC4 (2.99.4) 12.10 No ?
ZOTAC ZBOX AD04 PLUS Radeon HD 6320 ? Zacate Yes HDMI Denon AVR-1713 ? Yes Yes No No No ? Yes XBMCbuntu 12.0 "FRODO" ? Yes XBMC v12.0
Zotac ZBOX AD06 Radeon HD 7340 ? Zacate Yes HDMI Samsung AV-R720 ? Yes Yes No No No ? Yes OpenELEC 3.0.0 12.10? Yes ?
M5A78L-M/USB3 Radeon HD 6850 ? Barts No HDMI Denon AVR-4310 ? Yes Yes Yes Yes Yes Yes Yes OpenELEC (official) - 3.2.4 x64 ? No ?

4 Video harware setups reported to work avr-tv-htpc combo

Home icon grey.png   ▶ Audio hardware compatibility ▶ UNiversal
Wiki logo.png Wiki revamp:
This page or section of the wiki undergoing a revamp. Content is still being added and organized. Please pardon the dust and anything that might not be working.

55% Completed

If you ever asked the questions
  • What HTPC should I get?
  • What TV Should I get?
  • What AVR/Receiver should I get?
  • What Combination of the above 3 work best?
  • What OS should XBMC be on?
  • What drivers if any are reported to work?
  • What limitations does this machine/setup have over another?
  • What General capabilities does it have be it xyz audio/video?
Then this page is for you, ideally!


Notice: This page is a user generated/driven content, with their hardware and setup's that work or dont work in any of these situations.
Updating: Feel free to update this list accordingly and add fields to table for other video types your hardware can or cant do.


Please add your experience below.

4.1 Legend key

Legend - Templates - Formatting
General use indicator Decode indicator HTPC H/W Codename lookup External equipment
Yes No N/A w.i.p. ? cpu - vpu - gpu See:
ATI
See:
Nvidia
See:
Intel
See:
allwinner
See:
Freescale
See:
ARM
See:
Android
Plug - Receiver - TV / models
{{yes}} {{no}} {{NA}} {{wip}} {{?}} ''' cpu - vpu - gpu ''' '''HDMI''' '''Optical''' '''Analog''' '''TV - AVR / Model'''

4.2 Video hardware capabilities and reported to work

Note: H265 a.k.a. HEVC is not yet supported in XBMC (as of XBMC v13) Until next ffmpeg bump

Hardware and video playback compatibility
HTPC Hardware External Equipment Decoder Capabilities
Operative
System
Driver XBMC
Version
Model GPU - VPU type CPU type Code Names Limitation Plug Reveiver Television GPU
VPU
CPU
H.262 H.263 H.264 H.265 MPEG-4v3 WMV On2 720/1080 Blu-ray 3D Version Limitation
fictitious ugabuga holahoops armadillo Yes HDMI AVRBONGO Smugsung cpu gpu vpu ? No No Yes Yes N/A Yes Liwindra os ? w.i.p. V14-alpha1-7asd43e


5 Audio hardware setups reported to work htpc-avr-tv combos

Home icon grey.png   ▶ Video hardware compatibility ▶ UNiversal
Wiki logo.png Wiki revamp:
This page or section of the wiki undergoing a revamp. Content is still being added and organized. Please pardon the dust and anything that might not be working.

65% Completed


If you ever asked the questions
  • What HTPC should I get?
  • What TV Should I get?
  • What AVR/Receiver should I get?
  • What Combination of the above 3 work best?
  • What OS should XBMC be on?
  • What drivers if any are reported to work?
  • What limitations does this machine/setup have over another?
  • What General capabilities does it have be it xyz audio/video?
Then this page is for you, ideally!


Notice: This page is a user generated/driven content, with their hardware and setup's that work or dont work in any of these situations.
Updating: Feel free to update this list accordingly and add fields to table for other video types your hardware can or cant do.


Please add your experience below.

5.1 Legend key

Legend - Templates - Formatting
General use indicator Decode indicator HTPC H/W Codename lookup External equipment
Yes No N/A w.i.p. ? cpu - vpu - gpu See:
ATI
See:
Nvidia
See:
Intel
See:
allwinner
See:
Freescale
See:
ARM
See:
Android
Plug - Receiver - TV / models
{{yes}} {{no}} {{NA}} {{wip}} {{?}} ''' cpu - vpu - gpu ''' '''HDMI''' '''Optical''' '''Analog''' '''TV - AVR / Model'''

5.2 Audio hardware capabilities and reported to work

Note: Dolby Digital Plus a.k.a. DD+ or E-AC-3 is supported in AE > ActiveAE (as of XBMC v13) and will not work properly in XBMC 12.3 or Older.

5.3 AMD Based

Hardware and audio playback compatibility
HTPC Hardware External Equipment Audio Capabilities
Operative
System
Driver XBMC
Version
Model GPU - VPU type Audio device Code Name Limitation Plug Receiver Television AC3 LPCM DTS DTS-HD MA DTS-HD TrueHD DD+/E-AC3 Version Limitation
AMD A4-2800K APU Radeon HD 6450M ? Caicos No HDMI Denon ? Yes Yes Yes N/A Yes Yes Yes Windows 7 x64 Pro 12.1 No ?
AMD A4-3400 APU Radeon HD 6410D ? WinterPark No ? ? ? Yes Yes Yes N/A ? ? ? Windows 8 RTM 5.12.0.13 No ?
AMD A6-5400K APU Radeon HD 7540D ? Trinity No HDMI Onkyo TX-NR626 ? Yes Yes Yes N/A Yes Yes ? Windows 8 Pro, x64 9.0.0.9903 No ?
AMD A8-3870K APU Radeon HD 6550D ? BeaverCreek No ? ? ? Yes No Yes No No No ? Ubuntu 12.04 LTS 12.1 Yes ?
AMD A8-3870K APU Radeon HD 6550D ? BeaverCreek No ? ? ? ? Yes ? ? Yes Yes ? Windows 7 x64 Pro 12.4 No ?
ASRock E350M1 Radeon HD 6310 ? Wrestler No HDMI Onkyo HT-R380 ? Yes ? Yes Yes Yes Yes ? Windows 8 Pro, x64 13.2 Beta6 No ?
ASRock E350M1 Radeon HD 6310 ? Wrestler No HDMI Onkyo HT-R380 ? Yes ? Yes No No No ? OpenELEC 3.0 RC4 (2.99.4) 12.10 No ?
Asus E45M1-I Deluxe Radeon HD 6320 ? Zacate Yes HDMI Denon AVR-3312 ? Yes Yes No No No ? Yes OpenELEC 3.0 (RC 1) 12.10 Yes ?
ZOTAC ZBOX AD04 PLUS Radeon HD 6320 ? Zacate Yes HDMI Denon AVR-1713 ? Yes Yes No No No ? Yes XBMCbuntu 12.0 "FRODO" ? Yes XBMC v12.0
Zotac ZBOX AD06 Radeon HD 7340 ? Zacate Yes HDMI Samsung AV-R720 ? Yes Yes No No No ? Yes OpenELEC 3.0.0 12.10? Yes ?
M5A78L-M/USB3 Radeon HD 6850 ? Barts No HDMI Denon AVR-4310 ? Yes Yes Yes Yes Yes Yes Yes OpenELEC (official) - 3.2.4 x64 ? No ?

5.4 Nvidia Based

Hardware and audio playback compatibility
HTPC Hardware External Equipment Audio Capabilities
Operative
System
Driver XBMC
Version
Model GPU - VPU type Audio device Code Name Limitation Plug Receiver Television AC3 LPCM DTS DTS-HD MA DTS-HD TrueHD DD+/E-AC3 Version Limitation
Gigabyte GV-N560OC-1GI GeForce GTX 560 ? GF110/GF114 No HDMI N/A ? Yes Yes Yes N/A Yes Yes Yes OpenELEC 3.0 313.09 No Frodo 12.1
Asus ENGT430 DC SL DI GeForce GT 430 ? GF108 No HDMI N/A ? Yes Yes Yes N/A Yes Yes Yes Ubuntu 12.04 LTS 295.59 No Frodo 12.2
Asus ENGT520 GeForce GT 520 ? GF119 No HDMI Yamaha/HTR-4063 ? Yes Yes Yes N/A Yes Yes Yes Debian Wheezy 310.19 No ?
EVGA GTX550 GeForce GTX 550 ti ? GF116 No HDMI Sony/STR-DN610 ? Yes Yes Yes N/A Yes Yes Yes Ubuntu 12.10 304.43 No ?
Asus ENGTX560 GTX 560 TI ? GF110/GF114 No ? ? ? Yes Yes Yes N/A Yes Yes ? Ubuntu 12.04 LTS 304.43 No ?
Palit GT640 GeForce GT 640 ? GK107 No ? ? ? Yes Yes Yes N/A Yes Yes Yes Ubuntu 12.04 LTS 304.43 No ?
Asus GT610-SL-1GD3-L Geforce GT610 ? GF119 No HDMI Onkyo TX-NR807 ? Yes Yes Yes N/A Yes Yes Yes Slackware 13.37 310.19 No ?
Zotac GT430 Zone Edition GeForce GT 430 ? GF108 No ? ? ? Yes Yes Yes N/A Yes Yes Yes Windows 7 x64 Pro 306.97 No ?
Asrock ION 330HT GeForce 9400M G gpu - #dev2 G96a/G96b Yes HDMI ? Samsung
Series 5
Yes Yes Yes N/A No No ? Ubuntu 12.04.4 LTS 304.64 No XBMC-V13alpha7
ZOTAC GT 610 ZONE Ed. Geforce GT610 ? GF119 No HDMI Onkyo TX-SR608 ? Yes Yes Yes N/A Yes Yes Yes Win8 64bit + XBMCbuntu 331.65 No ?

5.5 Intel Based

Hardware and audio playback compatibility
Hardware and audio playback compatibility
HTPC Hardware External Equipment Audio Capabilities
Operative
System
Driver XBMC
Version
Model GPU - VPU type Audio device Code Name Limitation Plug Receiver Television AC3 LPCM DTS DTS-HD MA DTS-HD TrueHD DD+/E-AC3 Version Limitation
EXAMPLE HD4000 ? N/A No 313.09 No HDMI N/A Smugsung X Yes Yes Yes Yes ? Yes ? XBMCbuntu v13 V13-beta3-e3sd46g


6 Editor references

6.1 Old AMD audio table / format

Hardware and audio playback compatibility
Model Name GPU Code Name AC3 LPCM DTS DTS-HD MA DTS-HD TrueHD DD+/E-AC3 Driver Version Driver limitation HW Limitation Plug Receiver Operating System
AMD A4-2800K APU Radeon HD 6450M Caicos Yes Yes Yes Yes Yes Yes ? 12.1 No No HDMI Denon Windows 7 x64 Pro
AMD A4-3400 APU Radeon HD 6410D WinterPark Yes Yes Yes ? ? Yes ? 5.12.0.13 No No ? ? Windows 8 RTM
AMD A6-5400K APU Radeon HD 7540D Trinity Yes Yes Yes Yes Yes Yes ? 9.0.0.9903 No No HDMI Onkyo TX-NR626 Windows 8 Pro, x64
AMD A8-3870K APU Radeon HD 6550D BeaverCreek Yes No Yes No No No ? 12.1 Yes No ? ? Ubuntu 12.04 LTS
AMD A8-3870K APU Radeon HD 6550D BeaverCreek ? Yes ? Yes ? Yes ? 12.4 No No ? ? Windows 7 x64 Pro
ASRock E350M1 Radeon HD 6310 Wrestler Yes ? Yes Yes Yes Yes ? 13.2 Beta6 No No HDMI Onkyo HT-R380 Windows 8 Pro, x64
ASRock E350M1 Radeon HD 6310 Wrestler Yes ? Yes No No No ? 12.10 Yes No HDMI Onkyo HT-R380 OpenELEC 3.0 RC4 (2.99.4)
Asus E45M1-I Deluxe Radeon HD 6320 Zacate Yes Yes Yes No No No ? 12.10 Yes No HDMI Denon AVR-3312 OpenELEC 3.0 (RC 1)
ZOTAC ZBOX AD04 PLUS Radeon HD 6320 Zacate Yes Yes Yes No No No ? ? Yes No HDMI Denon AVR-1713 XBMCbuntu 12.0 "FRODO"
Zotac ZBOX AD06 Radeon HD 7340 Zacate Yes Yes Yes No No No ? 12.10? Yes No HDMI Samsung AV-R720 OpenELEC 3.0.0
M5A78L-M/USB3 Radeon HD 6850 Barts Yes Yes Yes Yes Yes Yes Yes ? No No HDMI Denon AVR-4310 OpenELEC (official) - 3.2.4 x64

6.2 Legend key Template

Legend - Templates - Formatting
General use indicator Decode indicator HTPC H/W Codename lookup External equipment
Yes No N/A w.i.p. ? cpu - vpu - gpu See:
ATI
See:
Nvidia
See:
Intel
See:
allwinner
See:
Freescale
See:
ARM
See:
Android
Plug - Receiver - TV / models
{{yes}} {{no}} {{NA}} {{wip}} {{?}} ''' cpu - vpu - gpu ''' '''HDMI''' '''Optical''' '''Analog''' '''TV - AVR / Model'''

6.3 AVWorklistHeader Template

Audio - Templates - Formatting
HTPC Hardware External Equipment Audio Capabilities
Operative
System
Driver XBMC
Version
Model GPU - VPU type Audio device Code Name Limitation Plug Receiver Television AC3 LPCM DTS DTS-HD MA DTS-HD TrueHD DD+/E-AC3 Version Limitation

6.4 VWorklistHeader Template

Hardware and video playback compatibility
HTPC Hardware External Equipment Decoder Capabilities
Operative
System
Driver XBMC
Version
Model GPU - VPU type CPU type Code Names Limitation Plug Reveiver Television GPU
VPU
CPU
H.262 H.263 H.264 H.265 MPEG-4v3 WMV On2 720/1080 Blu-ray 3D Version Limitation

6.5 Package management F.A.Q.

Here we give detailed information on Advanced Packaging Tool, a.k.a. APT. and the necessary commands to retrieve, install, update, upgrade and or remove the application also known as XBMC or Kodi on Ubuntu and variants such as XBMCbuntu/KodiBuntu. Such information is widespread on any Ubuntu documentation and is duplicated here for simplicity and general user base benefit.


6.5.1 Why are XBMC packages from Ubuntu repositories incorrect?

Link

The simple answer is that, these packages derive from externally modified XBMC versions which are either outdated and broken or both, and are 100% officially unsupported at this time.

The main thing you must understand is that if you looking for supported official builds, you simply should not use other repositories, unless otherwise indicated by a Team Member or a informed community member.

6.5.2 Are any dependencies required to manage repo's or ppa's?

Link

Some dependencies are required to manage ppa's/repos within your distro, install these by typing:

sudo apt-get install python-software-properties pkg-config

6.5.3 How do I find out what repo/ppa I am currently using?

Link

You can get a complete listing of what repositories are part of your sources list by typing:

sudo apt-cache policy

6.5.4 How do I add or remove ppa's?

Link

After you determined which ppa you would like to add or remove follow the instructions below.

You can remove a ppa from your distro's sources list via terminal, by typing
sudo add-apt-repository -r ppa:current_XBMC_providing_ppa
You can add a ppa to your distro's sources list via terminal, by typing
sudo add-apt-repository ppa:the_ppa_you_wish_to_use


Note:

  • The process of adding and removing repositories is recommended when changing the repo's in use.
  • Changing the PPA repo for XBMC will change what type of install is used (stable, nightly, beta, etc).

6.6 Installing, updating or upgrading

If applicable you can check what package versions are installed in your system, this is helpful when determining what procedures to choose.

6.6.1 How can check what current XBMC version is installed?

Link

Check what XBMC versions you have access to:

sudo apt-cache policy xbmc

6.6.2 How do I install XBMC?

Link

After adding or removing any ppa you need to refresh your sources list and finally install XBMC, by typing:

sudo apt-get update
sudo apt-get install xbmc xbmc-bin

6.6.3 How do I update XBMC?

Link

To update XBMC/Kodi when a new version is released, just do a general system/package or use the following commands in the terminal (or via SSH):

sudo apt-get update
sudo apt-get install xbmc xbmc-bin

6.6.4 How do I upgrade XBMC?

Link

After adding or removing any ppa you need to refresh your sources list and finally upgrade xbmc, by typing:

sudo apt-get update
sudo apt-get --only-upgrade install xbmc xbmc-bin

6.6.5 Why wont XBMC upgrade?

Link

After following the above instructions, XBMC is still not upgraded, the main reason why this happens is because the distribution you are using, is no longer supported and has reached an end of life status.

See Current Ubuntu releases if your current distro is listed under End of life table, you will need to upgrade your OS to a supported release.

LTS releases are better for long term install and forget, installing obviously the very latest LTS release available.

6.6.6 How do I upgrade the Kodibuntu base OS?

Link

To actually upgrade the underlying Linux which "Kodibuntu" is based on, it is possible to do so via release upgrade.

There are advantages and disadvantages to doing so. It's not a method recommended lightly to inexperienced users, doing so means you understand and accept responsibility for breaking your system.

BACKUP! Never attempt any upgrades without having proper backups of the files you consider important or value or have a full system image/backup of working system you can restore.
RECOMMENDED! It is possible (in order to preserve systems tweaks) to just upgrade Kodi itself by treating it as a normal Linux package and update/install via: Upgrading Kodi via ppa in Kodibuntu


sudo apt-get update
sudo apt-get install update-manager-core
sudo do-release-upgrade

This should upgrade your Base distribution, however if your current version is too old it may require repeating these steps until you reach the desired version. Do note that this is not recommended to inexperienced Linux users in case of breakages that you wont be able to resolve.

6.6.7 How to install a specific versions?

Link

In the event you need to install either by upgrade or downgrade a specific XBMC version (a reason may be a bug or to test a specific version), the PPA providing said version active must be in your sources.list.d along with a updated list of the packages. If the packages you intend to install are on a different PPA, you should probably remove that PPA to avoid confusion. apt-get install packagename=version is one way to achieve this.

sudo apt-get update
sudo apt-get install xbmc=2:13.1~git20140606.0917-gotham-0trusty xbmc-bin=2:13.1~git20140606.0917-gotham-0trusty

Hint: For e.g. You can use result of apt-cache policy xbmc to see the candidates <packagename><version> available to you. Note: Removing/purging any previous versions if they are greater version of the package you are looking to install is necessary.

6.6.8 How can I install a beta/unstable version?

Link

To install a beta/unstable version of XBMC you must first add the unstable repository, then install XBMC:

sudo add-apt-repository ppa:team-xbmc/unstable
sudo apt-get update
sudo apt-get install xbmc xbmc-bin
or
sudo add-apt-repository ppa:team-xbmc/nightly
sudo apt-get update
sudo apt-get install xbmc xbmc-bin

Follow the prompts to add the repository, then to add the updates, and finally install the new version of XBMC. Note: You may need to restart your computer for the newly installed version to be working.

6.6.9 How can I move from a beta/unstable to a stable version?

Link

Check what XBMC versions you have access to by typing:

sudo apt-cache policy xbmc

The response in terminal should be something like:

xbmc:
  Installed: 2:13.2~git20140719.0900-beta2-0trusty
  Candidate: 2:13.2~git20140719.0900-beta2-0trusty
  Version table:
 *** 2:13.2~git20140719.0900-beta2-0trusty 0
        500 http://ppa.launchpad.net/team-xbmc/unstable/ubuntu/ trusty/main amd64 Packages
        100 /var/lib/dpkg/status
     2:13.1~git20140606.0917-gotham-0trusty 0
        500 http://ppa.launchpad.net/team-xbmc/ppa/ubuntu/ trusty/main amd64 Packages
     2:12.3+dfsg1-3ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages

Note: In the above example we have an unstable (team-xbmc/unstable) and the release versions (team-xbmc/ppa) available. The version with the *** is the currently installed version (unstable)

To install the release version we need to install the team-xbmc/ppa version (in the above example: "2:13.1~git20140606.0917-gotham-0trusty"). This requires the install of both the "xbmc" and the "xbmc-bin" package.

sudo apt-get install xbmc=2:13.1~git20140606.0917-gotham-0trusty xbmc-bin=2:13.1~git20140606.0917-gotham-0trusty

Note: You will get a warning you are downgrading, hit Y when asked to continue

Remove the beta/unstable repository from XBMC to clean up:

sudo add-apt-repository -r ppa:team-xbmc/unstable

6.7 Uninstalling or Removing

6.7.1 How do I uninstall XBMC?

Link

If you need to remove and purge an application and finally removing/purging also the application configurations files, do so by typing:

sudo apt-get update
sudo apt-get remove xbmc*
sudo apt-get purge xbmc*

6.8 Build Dependencies

6.8.1 What are PPA build dependencies?

Link

These build dependencies are versions of a library pre-packaged by Team XBMC, because the distro provided versions are behind the current requirements of XBMC. Both REAME.linux and/or README.ubuntu documents using XBMC ppa build dependencies refer to these dependencies in the Team XBMC PPA's used in conjunction, when compiling on Ubuntu or derivatives distros.

6.9 See also

Personal tools
Namespaces

Variants
Actions
Navigation
Wiki help
Toolbox