XBMC will be renamed to Kodi for v14. Read here for more details

Troubleshooting

From Kodi
Revision as of 09:46, 27 July 2006 by Gamester17 (Talk)

Jump to: navigation, search

Before starting troubleshooting it's always a good idea to enable DebugLog in XBMC. This provides more detailed info on what's going on, this is done like this: link

Contents

1 Lost control

Why did my XBMC freeze? There is a new item on the rightside of the top of the screen and my controller isn't working.
That is the volume control or seekbar popup menu. It is assigned to the right thumbstick on the controller (up and down for volume, left and right for seeking). Try recalibrating your analog sticks by moving them in full circles several times. If this does not fix the problem, your controller may simply be more sensitive than others. Increase the value of <deadzone> in XBoxMediaCenter.xml.



2 Audio related issues

The volume level in XBMC is down really, really low – I can't hear anything!
The right thumb stick (push up or down) alters the volume level. Sometimes a second controller is tucked away and could be lowering the volume.


Help! My Music visualization doesn't change!
Milkdrop and Vortex support a locked mode where presets don't change automatically. This is toggled using controller and the File:2d btn back.png button. Notice that little padlock ?



3 Video output issues / Issues with video playback

I changed to another skin, and the screen went black. Now, whenever I boot XBMC it stays black and I can't do anything!
Hold down both thumbsticks (clicked) when launching or booting XBMC. This will cause a screen to pop up asking you if you want to reset your settings (including the active skin) to the defaults. The only settings not reset by this method is the Master lock code, and the advaced settings only accessable via manual edit of XML-files, (such as AdvancedSettings.xml, Keymap.xml, LCD.xml, RssFeeds.xml and PartyMode.xml).
I use XBMC in 1080i, and when I try and watch videos it fails. What can I do?
The Xbox comes equipped with 64Mb of unified RAM, which means that system and graphics memory are shared (unlike a standard PC where they are separate.) This means that when you use 1080i you have to be mindful of things that can take up memory:
  • Cache sizes
  • Skin used
  • Enabled services (Webserver, Ftpserver, Python)

Due to the shortage of RAM, it may be a wise idea to turn off all of the listed services at first until you know what can be sustained. A video cache size of 1Mb is more than enough for playback over a wired local network. If you use wireless, then you may need it slightly higher, though expect problems with streaming over wireless - wireless very rarely runs at it's advertised speed - often it is significantly slower, so experiment with placement of access points and the like.

When I play videos, they display using the wrong aspect ratio. What can I do to fix this?
XBMC has built-in aspect ratio control, as well as zoom control. This can be changed by use of the File:Btn y3.png button during video playback. When you press File:Btn y3.png you will also see which resolution it is using. If you find your 4x3 movies play on your 16x9 screen stretched out, instead of with black bars either side of the image, it may be that you have selected "Auto" as the video output resolution in the Video Player settings, and your TV does not auto-switch to it's 4x3 mode. Set it to 16x9 in this case. See Movie Playback & OSD for more information.
I can't seem to be able to select Widescreen/HDTV modes. How can I fix this?
You must enable Widescreen/HDTV Modes in the Microsoft Dashboard. Once this is done, the options will appear in XBMC.
Note: For HDTV modes you need two things. The xbox must be in NTSC mode and you also need a suitable AV cable.



4 XBMC won't start

I recently upgraded my XBMC and now it loads with a XBMC Fatal Load Error – Q
\XboxMediaCenter.xml, Line 0 – Failed to open file. I don't even have a Q: drive?
The Q: drive is the temporary drive that XBMC sets up in it's own directory. You probably did an edit to XboxMediaCenter.xml that broke the file (forgot to close a tag perhaps?) A good practise is to always verify the integrity by opening XboxMediaCenter.xml in a Webbrowser before uploading!
I try to launch XBMC from a dashboard and it does not start (freeze or black screen), why?
If you have a very old BIOS in your modchip, make sure that XBMC's XBE (executable) is patched from DEBUG to RETAIL, as old BIOS's can't run DEBUG executeables. You can patch it with xbepatch or deXBE. If you get same problem again try another build of XBMC, if still same issue follow EvoX FAQ.



5 XBMC won't play a file

I got one or several AVI files that plays choppy and/or ends in the middle of playback, what could be the cause?
There's basically 2 types of AVI files, AVI and AVI2.0. AVI2.0 is also known as OpenDML. If your file is encoded with XviD (or another MPEG-4 Codec) video and MP3 audio (use GSPOT to findout) this is almost certainly the cause to the playback problems. The issue can be resolved by RE-MUXING the video to old AVI format using a tool like AVIMux-GUI. If the file is a .MP4 file, it could be streamripped or just created as a Stream. Then you need to enable No Cache in Video OSD Settings.
Why can't Xbox Media Center read/play files larger than 1GB from a UDF DVD-R/RW media?
This is due to a Xbox™ limitation reading UDF128 (this is not a XBMC failure or our fault).
Why can't Xbox Media Center read/play files larger than 4GB from the Xbox™ harddrive?
This is due to a Xbox™ limitation in the FAT-X format (not a XBMC issue that can be fixed).
Why can't XBMC read/play AVI video files after 2GB or play/read a 2GB+ AVI video file?
All AVI files over 2GB in size are OpenDML AVI's and XBMC does not yet support OpenDML. PS! We know that XBMC also has other problems with OpenDML AVI's that are under 2GB in size. A couple of such problems are that XBMC cannot FF/RW in OpenDML, and/or video distortions. Note! Reason for this is that MPlayer which XBMC is based upon do not yet support OpenDML.



6 Network performance issues (wired or wireless)

Do you experince slow throughput/load-times when streaming video or audio over a wired or wireless-network? Here are some general hints and tips that can aid wired and wireless performance issues:

6.1 General (both wired and wireless) tips:

  • If your computers operating-system is windows based (like 95/98/ME/XP/2000/2003) then follow/perform this tweaks:
    • Tweak the DNS errors caching in windows by following the first in this url (link) to speedup/fix failed dns lookups.
    • Follow this tweakxp.com (link) register tweak to change the dir commad's buffer from 14000 to 65000 to raise the cache.
    • Uninstalled or reconfigure the "qos packet scheduler" service from the tcp/ip stack under properties in local area connection;
      • (Alernative 1: in windows => control panel => network connections => local area connection => properties => uninstall).
      • (Alernative 2: lower or disable the amount of bandwith reserved for qos, do this by following the last article in this link).
  • In windows make you you 'unmount' (or disable) all virtual cd/dvd-rom drives (ex. from daemon-tools, alcohol 120%, clonedvd/clonecd, etc.).
  • During smb streaming troubleshooting you should of course also (temporarly) try disabling any antivirus and firewall softwares on your computer.

6.2 Wired specific tips:

  • Force from "auto-detect speed" to "100mbps/full-duplex" becuase it disables auto-negotiation which can sometimes slow network connections, (in windows xp => control panel => network connections => local area connection properties => configure... => advanced => link speed...).

6.3 Wireless specific tips:

  • If your wireless access-point/router/adapters are 802.11b then upgrade (buy!) all to [802.11g, 802.11g+, 802.11n or 802.11a equipment with MIMO support instead. Know that in practice the maximum 802.11b throughput that an application can achieve is about 5.9Mbit/s (for burst transmission) and the average throughput is usually bellow 1Mb/second which is too slow to stream video in real-time. The average throughput for 802.11g is 25Mbit/s, and 50Mbit/s for 802.11g+ with MIMO so even that might have problems streaming DVD-Video movies over wireless. 802.11n on the other hand (which all support MIMO as standard) has an average throughput of 200Mbit/s, and that is fast enough for all audio/video streams.
  • Disable WEP/WPA encryption (as it increases overhead which lowers throughput), enable MAC-address filtering as security instead.
  • Move your wireless router/access-point and network-adapters closer to each other as the data-rates decreases significantly the longer the signal have to travel, also remove all possible obsticals if possible (as the data-rates slows down significantly if the signal have to travel through thick walls, floors/ceelings or furnature, etc.). In addition try to place your wireless router/access-point at the same hight as your network-adapters, preferably on the middle of the wall instead of on the floor or close to the ceeling.
  • Do not mix formats, the presence of an 802.11b participant significantly reduces the speed of an 802.11g/802.11g+ networks. Same with 802.11g and 802.11n. Also non-network wireless products, or other products that are operating in the 2.4GHz band (as 802.11b/802.11g/802.11g+ do), like microwave ovens, bluetooth devices, and cordless telephones

Note! If above don't help then test the alternative XBMSP/XBMS or UPnP protocols, instead of SMB/SAMBA/CIFS as they have much less overhead.

7 Annoyances

Where did the Record Button go?
It's in My Music OSD now
When I start the XBOX and XBMC there is a startup music that plays every restart or when I enter xbmc. How can I disable this music?
There is a script running on startup (scripts\autoexec.py) that is loading another script and causing playback to start. Remove the autoexec.py script (or rename it) to stop this. It was put there by whoever created your build. Furthermore, there is also a startup sound that can be played (a file named media\start.wav) which is normally played when the splash screen is displayed. Remove this file if you don't like it.
After I deleted some albums from my harddisk, they are still visible when in My Music Libary. How can I delete these empty albums?
Go to Settings->My Music and choose "Clean the music database".
I'm using XBMSP or SMB to share my music to XBMC, and whenever I go to browse the shared folders it takes a while and presents me with the message scanning media info...what is it doing and is there anyway to remove this scanning?
It is scanning the media files for tag information, so that it can display artist, title, year, genre, album information, as well as any embedded thumbnails. This takes a while over a network connection. You can turn this off completely by disabling ID3 tag reading in Settings->My Music. A better thing to do is to perform a Scan on the folders from My Music. This will store the retreived tag information in the database, allowing you to take advantage of the database views (using the Switch View button). See My Music for more information.
When XBMC loads, it always starts in My Music (or some other screen). How can I get it to start on the home page?
The most likely reason for this is you have altered the <startwindow> tag in XBoxMediaCenter.xml, or via the Appearance Settings. Set it to Home via the GUI, or 0 in <startwindow> to start on the homepage.
I get an error message Error: Out of memory loading picture when running slideshows
Running slideshows uses a large amount of memory – particularly when loading images. You could try freeing up memory by turning off any music you have running. See here under the section “How it works” for more information.
I upgraded XBMC and now I can no longer access my F partition?
You possibly upgraded from a build prior to 19th of March 2005, to a build made after this date. You also use an old Bios. A possible fix to this issue is to disable <AutodetectFG> (set to no) in XboxMediaCenter.xml.
Why can't I access X, Y or Z partition using eg. My Files or by FTP?
Early on a deciscion was made to make it a little 'harder' for new unknowing users to access X, Y or Z due to the fact that these are "cache partitions" and no data put there stays there. You can make a bookmark yourself for My Files or edit Filezilla Server.xml yourself and add these!







Personal tools
Namespaces

Variants
Actions
Navigation
Wiki help
Toolbox